Symptom:
Cannot start Retail Pro, The TechToolkit fails to open the database during startup.
– ORA-00600 [dbkif_find_next_record_1] error is present in the ALERT_RPROODS.LOG
Cause:
Typically this is the result of a sudden system shutdown that leaves Oracle in a state where it needs to do crash recovery during startup. The error found in the alert log is an ORA-00600 with this exact string as the first argument: “[dbkif_find_next_record_1], [], [], [], [], [], [], [], [], [], [], []”
The condition occurs while Oracle is performing an internal recovery process following a crash. The database fails to open due to a bug in a component that is used by Oracle for session recovery.
REF Oracle bug # 9139693
Solution:
Oracle patch 45 for 11G, not yet deployed as a part of RetailPro9.
Workaround:
The Oracle recommended work around is to do the following.
1. Shutdown the database
2. Browse to the following folder. “Oraclediagrdbmsrproodsrproodsir” in Windows 3. Rename this file “recovery_history.ir”
4. Restart the database
Resume use of the system